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	By using VisLog you will be able to enter borehole information including depth, coordinates, groundwater level, etc. and have a three-dimensional interactive view of the subsurface soil layers of the site. The ultimate aim of VisLog is to help users with making a 3D model of the soil layers close to real site conditions. Input data can be manually entered or imported from gINT or NovoLAB. User can enter data using the borehole editor page. When the model is built based upon the borehole information provided by user, user can zoom, pan and rotate the 3-dimensional model, print it or even save it as graphic formats or video.

 

Although all efforts have been undertaken to ensure that this software is of the highest possible quality and that the results obtained are correct, the authors do not warrant the functions contained in the program will meet your requirements or that the operation of the program will be uninterrupted or error-free. The authors are not responsible and assume no liability for any results or any use made thereof, nor for any damages or litigation that may result from the use of the software for any purpose. All results to be verified independently by user. 
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Vancouver, Canada


















	

	


	
		
			License Agreement

		

	
	
	
		


View our online End User License Agreement




	

	


	
		
			Licensing Help

		

	
	
	
		


View our online Licensing Help




	

	


	
		
			Units System

		

	
	
	
		


VisLog is not unit sensitive. However, you need to keep consistency when entering coordinates and depths. Please note if you use UTM coordinates or geocoding functions, Metric units are used; Therefore, all other units should be in Metric. 




	

	


	
		
			Getting Help

		

	
	
	
		




	

	[image: ]Help button is placed at the top-right corner of program dialog pages. 

In order to open the help content associated with a page, please click on ? button. Otherwise you can open the Help file from Help menu. 







[image: ] If you prefer the PDF or e-Book format, please refer to Users Manuals folder, located in the program installation folder. 


















	

	


	
		
			Introduction

		

	
	
	
		




	The user interface of VisLog is designed to be intuitive and easy to use. The main elements of the program's screen are shown in the following illustration. In general, the left portion of the page includes boreholes, soil profiles and layers. The right portion of the page comprises the 3D view of the subsurface soil layers. 
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A typical data entry flow starts with entering borehole data, and follows by defining soil profiles. You can toggle on/off various data layers and interact with the 3D viewer. When the model is made, you can export it to various formats.  











	

	


	
		
			Borehole Editor

		

	
	
	
		




	This page is used to add, edit or delete boreholes. You start by adding boreholes, one in a row, in the table at the top of the page. Please note that borehole data requires coordinates (local or UTM datum) but the program uses neutral units system:




 [image: ]




All input data in VisLog are unit-neutral; However, depth and coordinates of a borehole must be in the same units system. Remember that VisLog only deals with presentation of your data and no interpretation or data-manipulation is performed. 

Manual Data Entry

To enter a new borehole click on "Add new borehole" button on toolbar; a new empty row will be added to the end of the boreholes and soil layers table. Please enter borehole data in the new row and then enter soil layers of the borehole and test data on corresponding tables.  

Import From Text File

If you have already stored the boreholes data in a Text file, you can easily import them (using the yellow folder icon on top-right corner of tables) into VisLog . Please read The Import from File help page for more information. If your data is entered in an Excel file, save it to Text format and then import it to VisLog. 




[image: ] VisLog has a feature to import borehole data directly from gINT project files and from NovoLAB database.

 

[image: ] Test data can be any type of test performed in a borehole including SPT, CPT, Moisture Content, Vane Shear, Shear Wave Velocity, etc.

Coordinate Adjustment

Use the tab located below the borehole table to manipulate coordinates. 

Geocoding

This feature requires UTM coordinates of boreholes. Read more about geocoding in this article. 

 

[image: ] VisLog supports all soil classes defined in Unified Soil Classification System (USCS). For visualization purposes when you select a Soil Type from the drop-down list, VisLog automatically finds the Soil Group that it is associated with. Subsequently, the Soil Group color is used for visualization and drawing the soil profiles. To see how to manage Soil Grouping please read this article.











	

	


	
		
			Soil Profiles

		

	
	
	
		




	In order to draw a soil profile, you need to first complete data entry for boreholes. A list of all boreholes will be shown on the left side of the screen. Create a new Soil Profile using the + button at the top of the list of Soil Profiles. To include a borehole in an existing Soil Profile, follow these steps:
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Step 1

Click on the desired borehole.




Step 2

Hold the left mouse button and drag the selected borehole under the desired Soil Profile on the right side.

 

Step 3

Release the mouse button.




The selected borehole will be placed after the last borehole in the corresponding Soil Profile. Use the up and down toolbar buttons to edit the sequence order of the boreholes in a Soil Profile. 




Once a soil profile is defined/edited, the viewer will be automatically updated to reflect the change. Each soil layer along the profile has a unique color. Similar soil layers in adjacent boreholes will be automatically connected together. For more information on how to define soil groups and assign a color to a specific Soil Group, read this article.











	

	


	
		
			Options

		

	
	
	
		




	VisLog preferences can be set on this page. In toolbar menu select Tools4Options to set the preferences. 











	

	


	
		
			Working with 3D Viewer

		

	
	
	
		


The 3D viewer of VisLog allows user interaction with boreholes, soil profiles, tests, and so on. Various actions may be performed using the toolbar at the top or right side of the viewer:
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In order to rotate the model, hold the mouse middle button down, and move the mouse to rotate the scene. If that does not work on your mouse, click on the "3D Rotate" button from the toolbar (see above) and move the mouse to desired view.




	

	


	
		
			Soil Grouping

		

	
	
	
		




	With "Soil Class Grouping" you can define the texture of soil layers in 3D model. This page is accessible through Tools 4 Soil Group Manager.  The main idea behind soil grouping is to enable users to group the soil classes as per the requirements of each project. For example, CL and ML soil classes (according to USCS) may consider as one soil group in a given project; on the other hand, the exact soil classes can be two different groups in other projects. Following are the definitions of the terms used in this article:

 

Soil Class : Refers to conventional soil types in geology or geotechnical engineering. This may be USCS, AASHTO, etc. or even user defined soil/rock type. For example you can define new soil class as "New Red Granite" in your project (See here for more details)

Group : Represents a group of Soil Classes which will be shown on the VisLog viewer with the same texture.

Texture : Is the image pattern by which a Group of soil layers will be rendered on the VisLog viewer. You may also choose to use colors instead of textures (read more).

Library : Is a text file which will be saved on your hard-disk and hold the information regarding all defined Groups (list of Groups with their associated Soil Classes). Library files have lib extension and when you install the VisLog , a default library file is installed in VisLog installation folder. This file (defgrp.lib) should never be removed from your hard-disk. You may have several Library files on your computer and can activate them by selecting the Library file and pressing "Set As Default" button (see following illustration).

 

How to associate a soil type to a soil group?

1- Make sure the soil group exists in the left table. If necessary, add a new soil group to the bottom of the table.

2- Find the soil type on the right table and click on the corresponding row.

3- Click on the "Associated Group" column to open up the list of soil groups.

4- Select the desired soil group to which this soil type should be associated

 

To change the texture of a group, simply click on third column in the "Groups" table and locate the image file.











	

	


	
		
			Data Layers

		

	
	
	
		




	

	In VisLog , all available data layers could be turned on/off by using the checkbox before each item on "Data Layers" tab at the bottom-left portion of the screen. Also when a layer is selected, its transparency may be adjusted by the slide-bar below the list:




[image: ]

 



	Labels


	Borehole labels.





	Boreholes


	Represents all boreholes of this model.





	Profiles


	Represents all soil profiles defined by the user.





	Ground Surface


	Represents a triangulated 3D surface of the ground surface. This surface is triangulated based on top elevation of boreholes.





	Bottom Surface


	Represents a triangulated 3D surface of the bottom of boreholes. This feature may be especially useful when boreholes were terminated due to encountering bedrock; In this case, this surface shows the bedrock surface.





	Field Tests


	Represents the plots of field test data for each borehole. This field test data could be SPT, Vane Shear, CPT, DCPT and any other field test. This plots are dimensionless, so literally any test results can be presented using this feature.





	Water Table


	Represents a triangulated 3D surface of the water level based on boreholes data.





	Grids


	Gridlines show the bounding box of this 3D model.








 

Adjusting Transparency

To change the transparency level of each info-layer, simply click on it and then use the slide-bar to adjust the transparency of the object. While dragging, notice the change in transparency of the info-layer in the viewer.


















	

	


	
		
			Linked Objects

		

	
	
	
		




	This version of VisLog allows you to add 3D models created by other programs, to your VisLog models. Such external 3D models are referred to herein as 'Linked Objects' and may be of the type:





	Autodesk (*.dwg, *.dxf)

	3D Studio Max (*.3ds)

	Wavefront Object (*.obj)

	Stereolithography (*.stl)

	3D Printer Laser LAS (*.las)

	Points (*.asc)



[image: ]




The 'Linked Objects (external)' tab at the bottom-left portion of the page, shows a list of all external objects. You can change the visibility of each external object using the checkbox beside each item. 











	

	


	
		
			Geocoding

		

	
	
	
		




	Geocoding is the process of transforming a description of a location -such as a pair of coordinates, an address, or a name of a place- to a location on the earth's surface. This is particularly useful when you want to prepare the 3D model in Google Earth or obtain satellite image for a site. Both these features require geographical coordinates (i.e. latitude and longitude). VisLog uses Google server for geocoding. 




You can start geocoding by entering the approximate location of the site. By pressing the "Start Geocoding" button, the following steps will be taken by the program:





	The approximate address will be used to obtain the UTM zone of the site (e.g. Vancouver, Canada is located in zone U10),

	Using UTM zone, the Easting and Northing coordinates of the boreholes will be used to obtain latitude and longitude of each borehole location,

	The bounding latitude and longitude coordinates will be passed to Google server to obtain the satellite image of the site (this is approximate). You can open the satellite image by clicking on <Satellite Image> link. 



 

[image: ]




 [image: ] In order to use geocoding function, you need exact UTM coordinates of the boreholes. 











	

	


	
		
			Import

		

	
	
	
		


In addition to composing a 3D model by entering borehole data and creating soil profiles, you can import the following file formats into your model:





	borehole data, soil layers, and field testing data in Text (*.txt) format

	borehole data from gINT project file

	borehole data from NovoLAB database file

	3D models created in various 3D formats

	Drawings created by Autodesk in DXF and DWG formats






	

	


	
		
			From Text File

		

	
	
	
		




	If your boreholes data stored in a text file, you can import them directly to VisLog and save the data entry time. The first 8 columns should be arranged in the following order:


	Name

	Depth

	X

	Y

	Z

	Water Level

	Azimuth

	Plumbness
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			From gINT Project

		

	
	
	
		




	Please read our online documentation about importing from gINT files:











	

	


	
		
			From NovoLAB Database

		

	
	
	
		




	If you use our NovoLAB software for borehole log drafting and  lab test processing, you can import your borehole data from your NovoLAB project file. Use File → Import → from NovoLAB menu to open the import page:
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			From Various 3D Formats

		

	
	
	
		




	Please read the article about Linked Objects.











	

	


	
		
			From Autodesk DXF/DWG

		

	
	
	
		


Please read the article about Linked Objects.




	

	


	
		
			Export

		

	
	
	
		


You can export your VisLog model to image file, Autodesk DXF / DWG file, Google Earth file and 3D PDF file. 




	

	


	
		
			To Image

		

	
	
	
		


This feature is used to save the current view of the VisLog model as an image. To access this feature, click on File→Export→Image menu. 




	

	


	
		
			To Autodesk DXF/DWG

		

	
	
	
		


This feature is used to save the current model to AutoCad DXF format. This is especially useful when user wants to edit the soil profiles in AutoCAD. Click on File→Export→AutoCAD DXF R12 menu to save the model. 




	

	


	
		
			To Google Earth

		

	
	
	
		


You can export your VisLog model to Google Earth. Once ready, click on File→Export→Google Earth menu. This will show the following settings page:
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On this page, please specify the UTM zone of your site, adjust the camera settings and click 'Start'. 




	

	


	
		
			To 3D PDF

		

	
	
	
		


In its simplest form, a 3D PDF is a standard Adobe PDF document that contains interactive 3D content such as text and other data types, 2D Graphics, 3D Graphics (3D CAD data), plus from a user perspective: the ability to interact with the document on many levels (open an example here). 




You can export your VisLog model to 3D PDF format from File→Export menu. 
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Visit our website at http://www.novotechsoftware.com 




	

	


	
		
			Support

		

	
	
	
		


Send a support request http://www.novotechsoftware.com/contact-us/
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